Changeset 3922


Ignore:
Timestamp:
04/15/08 12:10:36 (12 years ago)
Author:
curtis
Message:

Fix dev-compile by adding an explicit list of source files that need Java 1.5.

Location:
trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/build.properties

    r3860 r3922  
    3232           jar/velocity-dep-1.5.jar:\ 
    3333           jar/visad-lite.jar 
     34 
     35# files requiring Java 1.5 (rather than Java 1.4) 
     36java15.dirs = loci/formats/auto/** 
    3437 
    3538# files to avoid copying into the build source tree 
  • trunk/build.xml

    r3887 r3922  
    477477 
    478478  <target name="dev-compile" description="compile classes in-place (no copy)"> 
     479    <!-- By default, source files should compile under Java 1.4 --> 
    479480    <javac srcdir="." destdir="." debug="true" classpath="${ext.jars}" 
    480481      deprecation="true" source="1.4" target="1.4"> 
    481482      <include name="loci/**"/> 
     483      <exclude name="${java15.dirs}"/> 
     484    </javac> 
     485    <!-- Source files requiring Java 1.5 --> 
     486    <javac srcdir="." destdir="." debug="true" classpath="${ext.jars}" 
     487      deprecation="true" source="1.5" target="1.5"> 
     488      <include name="${java15.dirs}"/> 
    482489    </javac> 
    483490  </target> 
Note: See TracChangeset for help on using the changeset viewer.