Ignore:
Timestamp:
02/24/12 10:27:24 (8 years ago)
Author:
melissa
Message:

Fix cppwrap-maven-plugin to work with Maven 3

We now iterate over all of the artifacts attached to a project, and include
them in the list of JARs to be added to the CLASSPATH.

Unfortunately, for this to fully work we need a couple of extra transitive
dependencies in the POM. There may be a better place to put these, but for now
it works.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/projects/cppwrap-maven-plugin/pom.xml

    r7730 r7896  
    4848      <artifactId>maven-project</artifactId> 
    4949      <version>${maven.version}</version> 
     50    </dependency> 
     51 
     52    <!-- FIXME: Eliminate these transitive dependencies.  Required for Maven 3 support. --> 
     53    <dependency> 
     54      <groupId>org.apache.velocity</groupId> 
     55      <artifactId>velocity</artifactId> 
     56      <version>1.6.4</version> 
     57    </dependency> 
     58    <dependency> 
     59      <groupId>jace</groupId> 
     60      <artifactId>jace</artifactId> 
     61      <version>r61</version> 
    5062    </dependency> 
    5163  </dependencies> 
Note: See TracChangeset for help on using the changeset viewer.