Ticket #150 (closed defect: worksforme)

Opened 12 years ago

Last modified 12 years ago

Assorted peculiar VisBio exceptions

Reported by: sorber Owned by: curtis
Priority: minor Milestone: visbio3.40
Component: visbio Severity:
Keywords: Cc:
Blocked By: Blocking:

Description

Curtis: here are three errors I found in a log file while cleaning up my home folder this evening. The first one looks like an old 'restore state' problem. The second one hasn't happened in a while. The third still happens on occasion, but seems to have nothing to do with VisBio--in fact, I might have even asked you about it before. Still, I thought I'd file a ticket rather than let anything go to chance.

Got this error starting Visbio rapidly loading sdub; rapidly loading sdub again while first instance still loading

java.lang.NullPointerException
	at loci.visbio.view.TransformLink.initState(TransformLink.java:272)
	at loci.visbio.state.StateManager.mergeStates(StateManager.java:443)
	at loci.visbio.view.TransformHandler.initState(TransformHandler.java:324)
	at loci.visbio.view.DisplayWindow.initState(DisplayWindow.java:332)
	at loci.visbio.state.StateManager.mergeStates(StateManager.java:443)
	at loci.visbio.view.DisplayManager.restoreState(DisplayManager.java:223)
	at loci.visbio.state.StateManager.restoreState(StateManager.java:240)
	at loci.visbio.state.StateManager.restoreState(StateManager.java:109)
	at loci.visbio.state.StateManager.checkCrash(StateManager.java:130)
	at loci.visbio.VisBioFrame.<init>(VisBioFrame.java:190)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
	at loci.visbio.VisBio.launch(VisBio.java:109)
	at loci.visbio.VisBio.main(VisBio.java:129)

Got this error Starting visbio, importing sdub, adding sdub overlays, creating a 2D display. Error occurs trying to add sdub overlays to display?v

Invalid image number #0 for file "sdub1.pic" (9 found)
Exception in thread "VisBio-BurnThread-sdub:sdub" java.lang.NullPointerException
  at java.util.Hashtable.put(Hashtable.java:396)
    at loci.visbio.data.DataCache.putCachedData(DataCache.java:130)
    at loci.visbio.data.DataCache.getData(DataCache.java:63)
    at loci.visbio.data.ImageTransform.getData(ImageTransform.java:203)
    at loci.visbio.view.TransformLink.getImageData(TransformLink.java:476)
    at loci.visbio.view.TransformLink.computeData(TransformLink.java:461)
    at loci.visbio.view.TransformLink.run(TransformLink.java:328)
    at java.lang.Thread.run(Thread.java:595)
}}

// This error or something like it occurs occasionally during startup of visbio.  It doesn't seem to affect the way the program works.
{{{
java.lang.NullPointerException
        at javax.swing.JComponent._paintImmediately(JComponent.java:4845)
        at javax.swing.JComponent.paintImmediately(JComponent.java:4666)
        at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:451)        at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:114)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
        at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)        at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
In paintImmediately null graphics
}}}  

Change History

comment:1 Changed 12 years ago by curtis

  • Milestone set to visbio3.4

comment:2 Changed 12 years ago by curtis

  • Status changed from new to closed
  • Resolution set to worksforme

I could not duplicate the TransformLink NullPointerException. Even if a subtle problem does exist there, it will almost certainly go away once I gut the state logic to be more manageable.

I have very rarely seen the "Invalid image number" error, and not for quite some time (and certainly haven't been able to duplicate it consistently), but if I see it again I will file a separate bug about it.

Same thing for the paintImmediately problem -- I very occasionally see it. Seems like a weird Swing bug. As stated, it doesn't affect the program's performance, so can be safely ignored. And since no VisBio code is directly involved, tracking it down without being able to reproduce it consistently would be nigh impossible anyway.

Note: See TracTickets for help on using tickets.