Ticket #166 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

LegacyQTReader is broken

Reported by: curtis Owned by: melissa
Priority: major Milestone:
Component: bio-formats Severity:
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by curtis) (diff)

When reading any QuickTime file with a codec that requires QTJava, an exception is thrown:

curtis@monk:~/data/quicktime/curtis$ showinf mri-stack-cinepak.mov 
...
Reading pixel data (0-26) Exception in thread "main" java.io.IOException: Close movie failed
        at loci.formats.in.LegacyQTReader.close(LegacyQTReader.java:120)
        at loci.formats.in.LegacyQTReader.close(LegacyQTReader.java:131)
        at loci.formats.FormatReader.initFile(FormatReader.java:111)
        at loci.formats.in.LegacyQTReader.initFile(LegacyQTReader.java:151)
        at loci.formats.FormatReader.setId(FormatReader.java:510)
        at loci.formats.FormatHandler.setId(FormatHandler.java:146)
        at loci.formats.in.QTReader.openImage(QTReader.java:271)
        at loci.formats.ImageReader.openImage(ImageReader.java:289)
        at loci.formats.ConsoleTools.testRead(ConsoleTools.java:384)
        at loci.formats.ImageReader.main(ImageReader.java:547)
Caused by: loci.formats.ReflectException: No such variable: openMovieFile
        at loci.formats.ReflectedUniverse.exec(ReflectedUniverse.java:250)
        at loci.formats.in.LegacyQTReader.close(LegacyQTReader.java:112)
        ... 9 more

I strongly suggest adapting the code from ImageJ's QTJava-based QuickTime reader, which works, rather than attempting to debug this problem as-is.

Change History

comment:1 Changed 12 years ago by curtis

  • Description modified (diff)

comment:2 Changed 12 years ago by melissa

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r3179. Rewriting LegacyQTReader was not necessary, as this was actually a very trivial bug.

Note: See TracTickets for help on using tickets.