Ticket #169 (closed defect: fixed)

Opened 12 years ago

Last modified 9 years ago

LegacyQTWriter cannot save using Motion JPEG-B codec

Reported by: curtis Owned by: melissa
Priority: trivial Milestone:
Component: bio-formats Severity:
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by curtis) (diff)

When attempting to save using the Motion JPEG-B codec, there is a failure within the QuickTime for Java code claiming that the codec is not present, even though QTJava reports it as available elsewhere:

curtis@monk:~/java$ java MakeQT ~/data/ome-tiff/curtis/time-series.ome.tif out.mov
loci.formats.ReflectException: Cannot instantiate object
        at loci.formats.ReflectedUniverse.exec(ReflectedUniverse.java:239)
        at loci.formats.out.LegacyQTWriter.saveImage(LegacyQTWriter.java:175)
        at loci.formats.out.QTWriter.saveImage(QTWriter.java:227)
        at MakeQT.main(MakeQT.java:19)
Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
        at loci.formats.ReflectedUniverse.exec(ReflectedUniverse.java:233)
        ... 3 more
Caused by: quicktime.std.StdQTException[QTJava:7.2.0g],-8961=noCodecErr,QT.vers:7208000
        at quicktime.std.StdQTException.checkError(StdQTException.java:38)
        at quicktime.std.image.CSequence.begin(CSequence.java:137)
        at quicktime.std.image.CSequence.<init>(CSequence.java:81)
        ... 8 more

For now, we can leave the option to save as Motion JPEG-B commented out, since such support is not a high priority.

Attachments

MakeQT.java Download (648 bytes) - added by curtis 12 years ago.
Example program that attempts to write a QuickTime movie using mjpb.

Change History

Changed 12 years ago by curtis

Example program that attempts to write a QuickTime movie using mjpb.

comment:1 Changed 12 years ago by curtis

  • Description modified (diff)

comment:2 Changed 9 years ago by curtis

  • Status changed from new to closed
  • Resolution set to fixed

moved to  ome:#4088

Note: See TracTickets for help on using tickets.