Ticket #209 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

OME download is broken

Reported by: curtis Owned by: curtis
Priority: major Milestone: visbio3.40
Component: visbio Severity: critical
Keywords: Cc:
Blocked By: Blocking:

Description

The latest version of VisBio fails to download from an OME server, due to a missing class:

Caused by: java.lang.NoClassDefFoundError: loci/plugins/Util
	at loci.ome.util.OMEUtils.showTable(OMEUtils.java:248)
	at loci.visbio.ome.OMEImage.makeTransform(OMEImage.java:219)
	at loci.visbio.ome.OMEImage.makeTransform(OMEImage.java:187)
	... 32 more

The problem is that loci.plugins.Util.addScrollBars is being called. However, that method was intended for use with ImageJ and its plugins only -- there is no reason for VisBio to be calling it. The reason it's called is that VisBio and ImageJ share a utility method, loci.ome.util.OMEUtils.showTable, for displaying image results from the search.

These classes need to be reorganized to make more sense and circumvent this problem.

Change History

comment:1 Changed 12 years ago by curtis

  • Milestone set to visbio3.4

comment:2 Changed 11 years ago by curtis

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r4005.

Note: See TracTickets for help on using tickets.