Ticket #232 (closed defect: invalid)

Opened 12 years ago

Last modified 12 years ago

Fix TIFF performance issues

Reported by: melissa Owned by: melissa
Priority: critical Milestone:
Component: bio-formats Severity: critical
Keywords: Cc:
Blocked By: Blocking:

Description

Some TIFF files take an unacceptably long time to initialize - see tiff/glen/742015a20x3middle16bit.tif for an example. This is a 16MB file, and takes well over 5 minutes to initialize.

This is a relatively recent occurence, as TIFFs used to read rather quickly. Ideally, this should be fixed before the December 28 release.

Change History

comment:1 Changed 12 years ago by melissa

  • Status changed from new to closed
  • Resolution set to invalid

This is/was caused by simultaneously reading 4+ datasets from the Samba share. Reading a local copy of the file mentioned above takes less than 30 seconds.

Note: See TracTickets for help on using tickets.