Ticket #29 (closed defect: fixed)

Opened 13 years ago

Last modified 13 years ago

Zeiss LSM/MDB bug: "No such method: mdb_open"

Reported by: curtis Owned by: melissa
Priority: major Milestone:
Component: bio-formats Severity:
Keywords: visbio Cc:
Blocked By: Blocking:

Description (last modified by curtis) (diff)

VisBio throws an exception when attempting to open data/zeiss-lsm/josh/081806.mdb/2a.lsm:

loci.formats.ReflectException: No such method: mdb_open
	at loci.formats.ReflectedUniverse.exec(ReflectedUniverse.java:244)
	at loci.formats.in.MDBParser.parseDatabase(MDBParser.java:94)
	at loci.formats.in.ZeissLSMReader.initMetadata(ZeissLSMReader.java:597)
	at loci.formats.in.BaseTiffReader.initFile(BaseTiffReader.java:819)
	at loci.formats.in.ZeissLSMReader.initFile(ZeissLSMReader.java:160)
	at loci.formats.in.BaseTiffReader.getImageCount(BaseTiffReader.java:662)
	at loci.formats.ImageReader.getImageCount(ImageReader.java:201)
	at loci.visbio.data.DatasetPane.buildPage(DatasetPane.java:390)
	at loci.visbio.data.DatasetPane$1.run(DatasetPane.java:241)
loci.formats.ReflectException: No such method: mdb_open
	at loci.formats.ReflectedUniverse.exec(ReflectedUniverse.java:244)
	at loci.formats.in.MDBParser.parseDatabase(MDBParser.java:94)
	at loci.formats.in.ZeissLSMReader.initMetadata(ZeissLSMReader.java:597)
	at loci.formats.in.ZeissLSMReader.initFile(ZeissLSMReader.java:230)
	at loci.formats.in.BaseTiffReader.getImageCount(BaseTiffReader.java:662)
	at loci.formats.ImageReader.getImageCount(ImageReader.java:201)
	at loci.visbio.data.DatasetPane.buildPage(DatasetPane.java:390)
	at loci.visbio.data.DatasetPane$1.run(DatasetPane.java:241)

I filed this bug with Bio-Formats since the exception ultimately happens within MDBParser, but it is unclear whether the problem is with Bio-Formats, VisBio, or a packaging issue.

Change History

comment:1 Changed 13 years ago by curtis

  • Description modified (diff)

comment:2 Changed 13 years ago by curtis

  • Description modified (diff)

comment:3 Changed 13 years ago by melissa

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r2481.

Note: See TracTickets for help on using tickets.