Ticket #431 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Feedback 1012: ArrayIndexOutOfBound in Slidebook

Reported by: omero-qa Owned by: melissa
Priority: critical Milestone:
Component: from QA Severity: serious
Keywords: Cc: ajs17@…
Blocked By: Blocking:

Change History

comment:1 Changed 10 years ago by melissa

  • Status changed from new to closed
  • Resolution set to fixed

For those who don't have access to the QA, here is the error:

java.lang.ArrayIndexOutOfBoundsException

at loci.common.RandomAccessInputStream.read(RandomAccessInputStream.java:424) at loci.common.RandomAccessInputStream.read(RandomAccessInputStream.java:397) at loci.formats.FormatReader.readPlane(FormatReader.java:322) at loci.formats.in.SlidebookReader.openBytes(SlidebookReader.java:92) at loci.formats.ImageReader.openBytes(ImageReader.java:339) at loci.formats.ChannelFiller.openBytes(ChannelFiller.java:172) at loci.formats.ChannelSeparator.openBytes(ChannelSeparator.java:177) at loci.formats.ReaderWrapper.openBytes(ReaderWrapper.java:273) at loci.formats.MinMaxCalculator.openBytes(MinMaxCalculator.java:246) at loci.formats.MinMaxCalculator.openBytes(MinMaxCalculator.java:229) at ome.formats.importer.OMEROWrapper.openPlane2D(OMEROWrapper.java:111) at ome.formats.importer.ImportLibrary.importData(ImportLibrary.java:464) at ome.formats.importer.ImportLibrary.importImage(ImportLibrary.java:325) at ome.formats.importer.gui.ImportHandler.importImages(ImportHandler.java:182) at ome.formats.importer.gui.ImportHandler.access$100(ImportHandler.java:45) at ome.formats.importer.gui.ImportHandler$2.run(ImportHandler.java:97) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:98) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:207) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:637)

The cause of the exception has been fixed in r5762.

Note: See TracTickets for help on using tickets.