Ticket #495 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

Lookup tables are not correctly applied if there is one LUT per channel

Reported by: melissa Owned by: curtis
Priority: major Milestone: bio-formats-4.2
Component: plugins Severity: serious
Keywords: Cc:
Blocked By: Blocking:

Description

See for example the first series of data/leica/joel/sequential scan 2/sequential scan 2.lei. There are two channels; the first should have a red LUT, the second should have a grey LUT (you can see this using 'showinf').

However, the ImageJ import plugin applies the red LUT to both channels when 'Color mode' is set to 'Default'. Previous stable releases correctly applied the grey LUT to the second channel.

Change History

comment:1 Changed 10 years ago by curtis

  • Status changed from new to assigned

comment:2 follow-up: ↓ 3 Changed 10 years ago by curtis

The "sequential scan 2" dataset reports that isIndexed=false, but has an 8-bit color lookup table:

	Indexed = false (false color, 8-bit LUT: 3 x 256)

Is this by design, or is this a bug?

comment:3 in reply to: ↑ 2 Changed 10 years ago by curtis

Replying to curtis:

Indexed = false (false color, 8-bit LUT: 3 x 256)

Strangely, on another one of my systems, with r6481, the isIndexed flag returns true:

	Indexed = true (false color, 8-bit LUT: 3 x 256)

I'll double-check the first system's result tomorrow, just to be sure.

comment:4 Changed 10 years ago by curtis

It may be that isIndexed=false when using the "-nometa" flag with showinf. This is related to #496.

comment:5 Changed 10 years ago by melissa

  • Status changed from assigned to closed
  • Resolution set to fixed

(In [6500]) Apply one LUT to each channel if the original file contains its own LUTs. Closes #495.

comment:6 Changed 9 years ago by melissa

  • Status changed from closed to reopened
  • Resolution fixed deleted

This bug was reintroduced in r6554 (trunk) and r6555 (4.2 branch).

comment:7 Changed 9 years ago by curtis

  • Status changed from reopened to closed
  • Resolution set to fixed

(In [6598]) Preserve channel-specific LUTs. Fixes #495 (again).

comment:8 Changed 9 years ago by melissa

  • Milestone bio-formats-4.2 deleted

Milestone bio-formats-4.2 deleted

comment:9 Changed 9 years ago by melissa

  • Milestone set to bio-formats-4.2
Note: See TracTickets for help on using tickets.