Ticket #571 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Bug when Pump is used in a LightSourceSettings

Reported by: callan Owned by: callan
Priority: blocker Milestone: bio-formats-4.2.1
Component: bio-formats Severity: serious
Keywords: Cc: ajpatterson@…
Blocked By: Blocking:

Description

If a Pump is then referenced in a LightSourceSettings, there is a referential clash that causes a ClassCastException during reference resolution:

Exception in thread "main" loci.formats.FormatException: loci.common.services.ServiceException: java.lang.ClassCastException: ome.xml.model.LightSourceSettings cannot be cast to ome.xml.model.LightSource
    at loci.formats.in.OMEXMLReader.initFile(OMEXMLReader.java:291)
    at loci.formats.FormatReader.setId(FormatReader.java:1067)
    at loci.formats.ImageReader.setId(ImageReader.java:644)
    at loci.formats.tools.ImageConverter.testConvert(ImageConverter.java:188)
    at loci.formats.tools.ImageConverter.main(ImageConverter.java:291)
Caused by: loci.common.services.ServiceException: java.lang.ClassCastException: ome.xml.model.LightSourceSettings cannot be cast to ome.xml.model.LightSource
    at loci.formats.services.OMEXMLServiceImpl.createRoot(OMEXMLServiceImpl.java:240)
    at loci.formats.services.OMEXMLServiceImpl.createOMEXMLMetadata(OMEXMLServiceImpl.java:192)
    at loci.formats.services.OMEXMLServiceImpl.createOMEXMLMetadata(OMEXMLServiceImpl.java:184)
    at loci.formats.in.OMEXMLReader.initFile(OMEXMLReader.java:285)
    ... 4 more
Caused by: java.lang.ClassCastException: ome.xml.model.LightSourceSettings cannot be cast to ome.xml.model.LightSource
    at ome.xml.model.Laser.link(Laser.java:214)
    at ome.xml.model.OMEModelImpl.resolveReferences(OMEModelImpl.java:130)
    at loci.formats.services.OMEXMLServiceImpl.createRoot(OMEXMLServiceImpl.java:236)
    ... 7 more

Change History

comment:1 Changed 9 years ago by callan

  • Status changed from new to assigned

comment:2 Changed 9 years ago by callan

  • Status changed from assigned to closed
  • Resolution set to fixed

(In [7013]) Resolving issues with Reference instances (with their referrer ID) ending up in the model object hash; includes test case. (Fixes #571)

Note: See TracTickets for help on using tickets.