Ticket #65 (closed defect: fixed)

Opened 13 years ago

Last modified 13 years ago

Cache indicators can report erroneous caching situation

Reported by: curtis Owned by: curtis
Priority: major Milestone:
Component: browser Severity: fatal
Keywords: visbio Cc:
Blocked By: Blocking:

Description (last modified by curtis) (diff)

If the dimensional scroll bars are clicked through too quickly on some systems, the graphical cache indicators can become screwed up. One easy way to duplicate the problem is to open data/fv1000/glen/seqlinestack.oif in the Data Browser with default settings, then try double clicking the z-depth scroll bar's right arrow as quickly as possible. When the bug happens, the indicator will populate with red from the left-hand side all the way to the current position. If it does not happen immediately, try clicking a few times quickly. If it still does not occur, try on another machine.

Given the timing required, the problem is probably a race condition between the AWT thread and the background caching thread. It is difficult to tell whether the cache itself is corrupted, or merely the indicator.

Refactoring the 4D Data Browser's cache manager to form the basis of VisBio's caching logic (ticket #49) may incidentally solve this problem as well.

Change History

comment:1 Changed 13 years ago by curtis

  • Keywords visbio added

comment:2 Changed 13 years ago by curtis

  • Description modified (diff)

comment:3 Changed 13 years ago by melissa

  • Status changed from new to closed
  • Resolution set to fixed
  • Severity set to fatal

Seems to be fixed in r3362 - as of that revision, the 4D data browser uses loci.formats.cache, instead of its own caching logic.

Note: See TracTickets for help on using tickets.