Ticket #70 (closed task: fixed)

Opened 13 years ago

Last modified 11 years ago

Additional OME-TIFF sample data

Reported by: curtis Owned by: curtis
Priority: critical Milestone:
Component: docs Severity: non-issue
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by curtis) (diff)

The  OME-TIFF sample data and benchmarks web page provides three sample OME-TIFF datasets distributed across multiple files. We really need a plethora of examples, of varying experiment types and configurations. For example, many developers (e.g., Karsten Kottig) would like to store everything in one file, rather than distributed across multiple files.

We should augment our current examples by creating and posting at least the following additional samples:

  • Single channel
  • Multi-channel
  • Z series
  • Multi-channel Z series
  • Time series
  • Multi-channel time series
  • 4D (Z and time)
  • Multi-channel 4D (Z and time)
  • Multi-position (successive stage positions)

Each sample should be stored in a single OME-TIFF file. For distributing across multiple files, the existing tubhiswt example, coupled with the  Distributing an image sequence across multiple OME-TIFF files section of the OME-TIFF specification, should be sufficiently enlightening. We need merely mention that any of the examples could be split into multiple files, or not, as desired.

We should also include a note about other kinds of data, particularly FLIM. It does not really make sense to store lifetime data as OME-TIFF, but it can be done. The problem is merely that each TIFF plane is kind of useless, making moot much of the utility of using the TIFF legacy format.

Change History

comment:1 Changed 13 years ago by curtis

  • Description modified (diff)

comment:2 Changed 12 years ago by curtis

I have posted a bunch of artificial datasets covering most of the cases above. However, it would still be nice to have some additional, newer biological sample datasets, particularly with the new versions of the OME-XML and OME-TIFF specifications as they become available, so I'll leave this ticket open until all the sample data has been updated. Once ome-xml.org exists, these samples should probably be posted there.

comment:3 Changed 12 years ago by curtis

  • Severity set to non-issue
  • Milestone set to bio-formats-m1

comment:4 Changed 11 years ago by curtis

  • Status changed from new to closed
  • Resolution set to fixed

As of a few weeks ago, the tubhiswt datasets have been updated to use the 2008-02 schema version, with the UUID method of distributing the image across multiple OME-TIFF files. All of the sample data should now validate properly with the online OME-XML validator, as well as the Bio-Formats command line XML validator.

comment:5 Changed 11 years ago by curtis

  • Milestone bio-formats-m1 deleted

Milestone bio-formats-m1 deleted

Note: See TracTickets for help on using tickets.