Ticket #814 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

won't open or create IRF

Reported by: payoung2 Owned by: aivar
Priority: major Milestone:
Component: slim-plugin Severity: serious
Keywords: Cc:
Blocked By: Blocking:

Description

I just did the usual stuff. Open FIJI. Click Analysis>Lifetime>Spectral lifetime analysis. I tried a few different images, and they all gave me this error....

(Fiji Is Just) ImageJ 1.47q; Java 1.6.0_24 [64-bit]; Windows 7 6.1; 93MB of 4991MB (1%) java.lang.NoClassDefFoundError: org/scijava/nativelib/NativeLibraryUtil

at loci.curvefitter.SLIMCurveFitter.fitData(SLIMCurveFitter.java:215) at loci.slim.SLIMProcessor.fitPixel(SLIMProcessor.java:2264) at loci.slim.SLIMProcessor.fitPixel(SLIMProcessor.java:2170) at loci.slim.SLIMProcessor.access$3400(SLIMProcessor.java:139) at loci.slim.SLIMProcessor$FittingCursorListener.cursorChanged(SLIMProcessor.java:2780) at loci.slim.fitting.cursor.FittingCursor.notifyListeners(FittingCursor.java:749) at loci.slim.fitting.cursor.FittingCursor.sendNotifications(FittingCursor.java:148) at loci.slim.SLIMProcessor.updateDecayCursors(SLIMProcessor.java:1282) at loci.slim.SLIMProcessor.showGrayScaleAndFit(SLIMProcessor.java:972) at loci.slim.SLIMProcessor.doFits(SLIMProcessor.java:871) at loci.slim.SLIMProcessor.process(SLIMProcessor.java:312) at loci.slim.SLIM_PlugIn.run(SLIM_PlugIn.java:61) at ij.IJ.runUserPlugIn(IJ.java:194) at ij.IJ.runPlugIn(IJ.java:160) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at ij.Command.runPlugIn(Command.java:148) at ij.Command.runCommand(Command.java:97) at ij.Executer.run(Executer.java:64) at java.lang.Thread.run(Thread.java:662)

Caused by: java.lang.ClassNotFoundException: org.scijava.nativelib.NativeLibraryUtil

at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:307) at fiji.FijiClassLoader.loadClass(FijiClassLoader.java:266) at fiji.FijiClassLoader.loadClass(FijiClassLoader.java:217) at fiji.FijiClassLoader.loadClass(FijiClassLoader.java:212) ... 22 more

Then I tried to load an IRF, and it wouldn't let me. Then I tried to use current XY, and it didn't like that either.

Thanks, Pam

Change History

comment:1 Changed 6 years ago by curtis

  • Component changed from other to slim-plugin

comment:2 Changed 6 years ago by aivar

  • Status changed from new to closed
  • Resolution set to fixed

The native library loader jar name & API changed in Fiji without corresponding changes in SLIM Plugin.

comment:3 Changed 6 years ago by curtis

You're referring to the native-lib-loader dependency of curve-fitter? You fixed it over a year ago in  f0d695b3. Then I updated it to use the 2.0.0 release version in  f5ac69b4. So this was really more an issue of the correct JARs not being uploaded to the ImageJ update site(s), isn't it?

Anyway, as long as all works now, no worries.

Note: See TracTickets for help on using tickets.