Ticket #815 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

why is my slim plugin broken.

Reported by: payoung2 Owned by: aivar
Priority: major Milestone:
Component: slim-plugin Severity: serious
Keywords: Cc:
Blocked By: Blocking:

Description

When I try to open an image to analyze using SLIM pluggin, I get this error. And it won't fit images for me.

(Fiji Is Just) ImageJ 1.48a; Java 1.6.0_24 [64-bit]; Windows 7 6.1; 66MB of 4991MB (1%) java.lang.NoClassDefFoundError: org/scijava/nativelib/NativeLibraryUtil

at loci.curvefitter.SLIMCurveFitter.fitData(SLIMCurveFitter.java:215) at loci.slim.SLIMProcessor.fitPixel(SLIMProcessor.java:2264) at loci.slim.SLIMProcessor.fitPixel(SLIMProcessor.java:2170) at loci.slim.SLIMProcessor.access$3400(SLIMProcessor.java:139) at loci.slim.SLIMProcessor$FittingCursorListener.cursorChanged(SLIMProcessor.java:2780) at loci.slim.fitting.cursor.FittingCursor.notifyListeners(FittingCursor.java:749) at loci.slim.fitting.cursor.FittingCursor.setTransientStop(FittingCursor.java:648) at loci.slim.fitting.cursor.FittingCursorHelper.setTransientStop(FittingCursorHelper.java:170) at loci.slim.ui.UserInterfacePanel$10.stateChanged(UserInterfacePanel.java:725) at javax.swing.JSpinner.fireStateChanged(JSpinner.java:434) at javax.swing.JSpinner$ModelListener.stateChanged(JSpinner.java:361) at javax.swing.AbstractSpinnerModel.fireStateChanged(AbstractSpinnerModel.java:102) at javax.swing.SpinnerNumberModel.setValue(SpinnerNumberModel.java:430) at javax.swing.JSpinner.setValue(JSpinner.java:329) at loci.slim.ui.UserInterfacePanel.setTransientStop(UserInterfacePanel.java:2245) at loci.slim.fitting.cursor.FittingCursorHelper.showFittingCursor(FittingCursorHelper.java:239) at loci.slim.fitting.cursor.FittingCursorHelper.access$100(FittingCursorHelper.java:44) at loci.slim.fitting.cursor.FittingCursorHelper$FittingCursorListener.cursorChanged(FittingCursorHelper.java:252) at loci.slim.fitting.cursor.FittingCursor.notifyListeners(FittingCursor.java:749) at loci.slim.fitting.cursor.FittingCursor.setDataStart(FittingCursor.java:562) at loci.slim.fitting.cursor.FittingCursorHelper.setDataStart(FittingCursorHelper.java:150) at loci.slim.ui.UserInterfacePanel$9.stateChanged(UserInterfacePanel.java:712) at javax.swing.JSpinner.fireStateChanged(JSpinner.java:434) at javax.swing.JSpinner$ModelListener.stateChanged(JSpinner.java:361) at javax.swing.AbstractSpinnerModel.fireStateChanged(AbstractSpinnerModel.java:102) at javax.swing.SpinnerNumberModel.setValue(SpinnerNumberModel.java:430) at javax.swing.JSpinner.setValue(JSpinner.java:329) at loci.slim.ui.UserInterfacePanel.setDataStart(UserInterfacePanel.java:2227) at loci.slim.fitting.cursor.FittingCursorHelper.showFittingCursor(FittingCursorHelper.java:238) at loci.slim.fitting.cursor.FittingCursorHelper.access$100(FittingCursorHelper.java:44) at loci.slim.fitting.cursor.FittingCursorHelper$FittingCursorListener.cursorChanged(FittingCursorHelper.java:252) at loci.slim.fitting.cursor.FittingCursor.notifyListeners(FittingCursor.java:749) at loci.slim.fitting.cursor.FittingCursor.sendNotifications(FittingCursor.java:148) at loci.slim.SLIMProcessor.updateDecayCursors(SLIMProcessor.java:1282) at loci.slim.SLIMProcessor.showGrayScaleAndFit(SLIMProcessor.java:972) at loci.slim.SLIMProcessor.doFits(SLIMProcessor.java:871) at loci.slim.SLIMProcessor.process(SLIMProcessor.java:312) at loci.slim.SLIM_PlugIn.run(SLIM_PlugIn.java:61) at ij.IJ.runUserPlugIn(IJ.java:196) at ij.IJ.runPlugIn(IJ.java:160) at ij.Executer.runCommand(Executer.java:128) at ij.Executer.run(Executer.java:64) at java.lang.Thread.run(Thread.java:662)

Caused by: java.lang.ClassNotFoundException: org.scijava.nativelib.NativeLibraryUtil

at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:307) at java.lang.ClassLoader.loadClass(ClassLoader.java:248) ... 43 more

Change History

comment:1 Changed 6 years ago by aivar

  • Status changed from new to closed
  • Resolution set to fixed

Fixed, was an issue with native library utility API changes.

Note: See TracTickets for help on using tickets.